Technical difficulties with in-app Feedback/Case submission
Incident Report for Net Health StatusPage
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 08:11 EST
Monitoring
We have identified the problem behavior and are working to develop a fix for the issue. If you need further assistance, please contact support via email at...

acutetherapy-support@nethealth.com
outpatienttherapy-support@nethealth.com
privatepracticetherapy-support@nethealth.com
or woundcare-support@nethealth.com for Woundcare support requests.

We apologize for the inconvenience and appreciate your patience.

Thank you,
Net Health team
Posted Dec 04, 2022 - 10:12 EST
Identified
We have identified the problem behavior and are working to develop a fix for the issue. If you need further assistance, please contact support via email at...

acutetherapy-support@nethealth.com
outpatienttherapy-support@nethealth.com
privatepracticetherapy-support@nethealth.com
or woundcare-support@nethealth.com for Woundcare support requests.

We apologize for the inconvenience and appreciate your patience.

Thank you,
Net Health team
Posted Oct 10, 2022 - 14:49 EDT
Investigating
Please be aware we are experiencing technical difficulties with our in-app Feedback/Case submission function within the Net Health Therapy for Hospitals–Acute, Hospitals–Outpatient, Private Practice application. If you need assistance from Net Health Support, please submit a case via email to one of the following email addresses -

acutetherapy-support@nethealth.com
outpatienttherapy-support@nethealth.com
privatepracticetherapy-support@nethealth.com

We apologize for the inconvenience and appreciate your patience as we work quickly to resolve this issue.

Thank you,
Net Health team
Posted Oct 07, 2022 - 16:38 EDT
This incident affected: Wound Care (WoundExpert) and Therapy for Hospital & Private Practice (Redoc xFit).