Billing Dashboard Latency

Incident Report for Net Health StatusPage

Resolved

All systems are operating normally, and no further latency has been reported with the Billing Dashboard.

If you experience any additional issues, please reach out to Net Health Support for assistance.

Thank you for your patience while we worked through this issue.

— The Net Health Team
Posted Oct 28, 2025 - 13:19 EDT

Investigating

We are actively investigating reports of latency impacting the Billing Dashboard, where certain dashboard buckets may take longer than expected to load.

Thank you for your patience as we work to address this issue.

Thank you,
The Net Health Team
Posted Oct 27, 2025 - 16:52 EDT
This incident affected: WoundExpert.