TherapySource Interface issues

Incident Report for Net Health StatusPage

Resolved

The issue affecting the TherapySource Interface has been successfully resolved. We appreciate your patience while we worked to address the incident.
Posted Oct 29, 2025 - 13:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 11:59 EDT

Update

We are continuing to investigate the issue.
Posted Oct 29, 2025 - 10:42 EDT

Investigating

Net Health is aware of an issue impacting the launch of additional applications within TherapySource.

Our Engineering team is actively investigating the cause and working to restore normal functionality as quickly as possible.
We’ll provide an update as soon as additional details become available.
We appreciate your patience and understanding.
Posted Oct 29, 2025 - 09:23 EDT
This incident affected: TherapySource.