TherapyC - Clinic Doc and Billing - slow performance
Incident Report for Net Health StatusPage
Resolved
Corrective actions were taken for Clinic Doc and Clinic Billing. Thank you for your patience.
Posted Sep 22, 2022 - 15:08 EDT
Investigating
Net Health is aware of an issue with slow performance in both Clinic Doc and Clinic Billing, and is investigating.
Posted Sep 22, 2022 - 11:52 EDT
This incident affected: Therapy for Clinics.