Maintenance ReDoc and Wound

Incident Report for Net Health StatusPage

Resolved

Maintenance has been completed,
Posted Oct 30, 2025 - 07:33 EDT

Investigating

We’ll be performing maintenance between 12:00 a.m. and 1:00 a.m. today, October 30, 2025. During this time, users may experience temporary service interruptions. Thank you for your patience.
Posted Oct 29, 2025 - 17:46 EDT
This incident affected: WoundExpert and ReDoc.