Latency in Net Health Therapy and Net Health Woundcare
Incident Report for Net Health StatusPage
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 10:02 EDT
Update
We are continuing to investigate the latency and apologize for the inconvenience. We appreciate your patience.

Thank you,
Net Health team
Posted Sep 07, 2022 - 16:24 EDT
Investigating
We are aware clients are experiencing latency within the Net Health Therapy and Net Health Wound Care applications. We have engaged IT and are working as quickly as possible to resolve the issue. We appreciate your patience.

Thank you,
Net Health team
Posted Sep 07, 2022 - 13:38 EDT
This incident affected: Wound Care (WoundExpert) and Therapy for Hospital & Private Practice (Redoc xFit).