This issue has been resolved. We are no longer receiving reports of latency with Batch Print, and the functionality is performing as expected.
Thank you to all affected clients for your patience and understanding as we worked through this. If you experience any related issues moving forward, please don’t hesitate to reach out to our Support team.
– The Net Health Team
Posted May 07, 2025 - 09:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2025 - 16:12 EDT
Investigating
We are currently investigating an issue affecting some users where Batch Print requests may become stuck in a loading state and fail to complete as expected. Our technical team is actively working to identify the root cause and implement a resolution.
We understand how critical this functionality is to your workflow and sincerely apologize for any disruption this may be causing.
Thank you for your continued patience and understanding. – The Net Health Team