Occupational Health - Hosted: Issues with launching Agility

Incident Report for Net Health StatusPage

Monitoring

A fix has been implemented and we are monitoring while users log back in.
Posted Sep 21, 2026 - 11:25 EDT

Identified

We've identified the cause of the login issues and are currently working on rolling out a fix as soon as possible.
Posted Sep 21, 2026 - 10:45 EDT

Investigating

We are currently investigating an issue with launching Agility.
Posted Sep 21, 2026 - 09:22 EDT
This incident affects: Occupational Health/Employee Health.