The performance issues and errors affecting the BI / Sisense Cloud application have been resolved. Dashboards and system functionality have returned to normal operation.
Thank you for your continued patience and partnership. The Net Health Business Intelligence Team
Posted Apr 15, 2026 - 15:59 EDT
Monitoring
Net Health continues to monitor performance within the BI / Sisense Cloud application following recent latency and error issues. Our leadership team remains in close contact with Sisense to ensure system stability and prevent recurrence.
We are actively tracking system performance and will provide further updates as needed.
Thank you for your continued patience and partnership. The Net Health Business Intelligence Team
Posted Apr 15, 2026 - 13:30 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 11:10 EDT
Identified
Net Health is aware that some users are currently experiencing performance issues within the BI / Sisense Cloud application, including latency and error messages when attempting to load dashboards.
Our team has escalated this issue directly to Sisense, and we are working closely with their team to identify the root cause and ensure long-term system stability.
We remain fully committed to restoring reliable performance and will continue to provide timely updates as they become available.
Thank you for your patience. The Net Health Business Intelligence Team
Posted Apr 15, 2026 - 11:06 EDT
This incident affected: Optima Business Intelligence.