Application Launcher Error - Your Connection Isn't Private

Incident Report for Net Health StatusPage

Investigating

The issue impacting application launches and causing "Your Connection Isn't Private" error messages has been resolved.

Clients should now be able to access and launch the application normally. We appreciate your patience while the Net Health team investigated and worked to restore service.

If you continue to experience issues, please contact Net Health Support for assistance.
Posted Aug 31, 2026 - 21:22 EDT

Monitoring

We've pinpointed the problem and are presently applying a solution.

Users have reported successful logins, and we're actively monitoring the situation.
Posted Aug 31, 2026 - 21:22 EDT

Investigating

We are aware that clients may be experiencing errors with launching the application due to "Your Connection isn't private" error messages after hitting Run.

The Net Health Team is working diligently to restore access to the application and we appreciate your patience.
Posted Aug 31, 2026 - 20:34 EDT
This incident affects: Optima.