Power BI Reports – Latency/Service Disruption

Incident Report for Net Health StatusPage

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 13:22 EDT

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 13:22 EDT

Investigating

We are currently investigating an issue affecting Power BI reports in WoundExpert. Users may experience these reports loading slowly or appearing to hang with a spinning indicator that does not complete.

Our team is actively investigating the root cause and working toward a resolution. We will provide updates as more information becomes available.

Thank you for your patience,

The Net Health Team
Posted Aug 21, 2026 - 13:09 EDT
This incident affects: WoundExpert and ReDoc.