Latency in BI / Sisense Cloud Application

Incident Report for Net Health StatusPage

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 10:44 EDT

Investigating

Net Health is aware that some users are currently experiencing latency issues within the BI / SiSense Cloud application.

Our leadership team has escalated the remaining performance concerns directly to SiSense, and we are working closely with their team on a daily basis to identify the root cause and ensure long-term system stability.

We remain fully committed to restoring reliable system performance and will continue to provide timely updates as new information becomes available.

Thank you for your continued patience and partnership.
Net Health Team
Posted Apr 02, 2026 - 10:43 EDT
This incident affects: Optima.