Batch Print Utility Latency

Incident Report for Net Health StatusPage

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 11:54 EDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 15:20 EDT

Investigating

We are aware of an issue affecting the Batch Print Utility, where users may experience latency or the service not responding. Our engineering team is actively investigating the cause and working on a resolution as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience. We will provide updates as soon as more information becomes available.

Thank you,
The Net Health Team
Posted Mar 17, 2025 - 12:38 EDT
This incident affected: WoundExpert and ReDoc.