Net Health Support has not received any additional reports of the issue. This incident is resolved.
Thank you, Net Health team
Posted Jun 27, 2025 - 11:16 EDT
Monitoring
We’ve implemented a fix and are actively monitoring for any further reports of the issue.
Thank you, The Net Health Team
Posted Jun 24, 2025 - 15:16 EDT
Update
We believe we’ve identified the root cause of the issue and are currently applying a fix while closely monitoring the results. At this time, we are seeing reports of successful logins. We’ll continue to provide updates as more information becomes available.
Posted Jun 24, 2025 - 12:02 EDT
Update
We are continuing to work diligently to resolve this issue as quickly as possible. Thank you for your patience and understanding. We will provide another update shortly.
Posted Jun 24, 2025 - 11:07 EDT
Investigating
We are aware that some clients are currently experiencing an "Execution Timeout Expired" error when attempting to log in or navigate within the Care Operations Management (COM) application.
Our team is actively investigating the issue and working to resolve it as quickly as possible.
We sincerely apologize for the inconvenience this may cause and appreciate your patience and understanding as we work to restore full functionality.