Occupational Health: Hosted Clients - Issue with servers affecting ability to launch apps

Incident Report for Net Health StatusPage

Resolved

This issue has been resolved. All users should be able to log in and access the application.
Posted Jun 13, 2025 - 13:19 EDT

Investigating

Our IT team is currently investigating the issue of no apps showing after logging in for some users. We apologize for the inconvenience and are working diligently to get this resolved as soon as possible.
Posted Jun 13, 2025 - 12:30 EDT
This incident affected: Occupational Health/Employee Health.