Batch Print Stuck in "Awaiting Completion"

Incident Report for Net Health StatusPage

Update

We've applied a fix for the issue affecting the batch print function in WoundExpert. Batch print jobs are now completing, and we are actively monitoring to confirm the issue is fully resolved.

If you continue to experience issues with batch print jobs, please try resubmitting the job. If it persists, please reach out to Support.

Thank you for your patience,
-The Net Health Team
Posted Aug 07, 2026 - 13:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2026 - 09:08 EDT

Investigating

We are currently investigating an issue affecting the batch print function in WoundExpert. Users may experience batch print jobs remaining stuck in "Awaiting Completion" status and never completing, regardless of the criteria or documentation view selected.

We are actively investigating the issue to resolve it as soon as possible. We will provide updates as more information becomes available.

Thank you for your patience,

- The Net Health Team
Posted Aug 06, 2026 - 18:26 EDT
This incident affects: WoundExpert.