Batch Print Not Loading

Incident Report for Net Health StatusPage

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 09:30 EST

Investigating

We are aware that some clients are experiencing an issue where batch print requests remain stuck on loading and do not complete. Our team is actively investigating and working toward a resolution.

We will provide updates as soon as more information becomes available and we thank you for your patience.

Thank you,
The Net Health Team
Posted Feb 17, 2025 - 14:43 EST
This incident affected: WoundExpert.