Business Intelligence Application Now Available

Incident Report for Net Health StatusPage

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 18:48 EDT

Monitoring

We’re pleased to inform you that the Business Intelligence application is once again available.

To ensure data accuracy and reliability, we performed a rollback of the environment. You can now access the application utilizing the existing URL and password.

If you have any questions or urgent needs during this time, please don’t hesitate to reach out to our support team at optima-support@nethealth.com. We’re here to help.

Thank you for your understanding and continued partnership.

Thank you,
Net Health Team
Posted Jun 07, 2025 - 15:39 EDT
This incident affected: Optima.