Issue with latest Citrix Workspace 2503 - Affecting hosted and self-hosted using Citrix

Incident Report for Net Health StatusPage

Investigating

We are aware of an issue with the latest Citrix Workspace client causing rendering issues. We recommend only using the current LTSR (Long Term Service Release) version, 2402.

To revert to the correct Citrix Workspace Client, have your IT follow the steps below:
1. Uninstall Net Health Citrix Driver.
2. Uninstall Citrix Workspaces.
3. Install Citrix Workspaces 2402 LTSR. https://www.citrix.com/downloads/workspace-app/workspace-app-for-windows-long-term-service-release/workspace-app-for-windows-LTSR-Latest.html?srsltid=AfmBOoougpc1nA4JW4C-KOOtDCY2iL7vvyDoYCdWLT2EnJOrf4UjRS4A
4. Re-install Net Health Citrix Driver.

Citrix Drivers per Agility version:
11.9 - 11.11 https://nethealth.sharefile.com/d-s92714d9f0e39448faa6b7d8494a3e448
11.12- 11.14 https://nethealth.sharefile.com/d-s3e34a48a847c408d93b810b11dfb22a9
11.15 -11.17 https://nethealth.sharefile.com/public/share/web-sf73c4243b522439096a84c837e3c3ab3

Older version 11.0 - 11.8 : https://nhsinc.sharefile.com/d-s05d95675e600493c98f5085359e97c3d
Posted Jun 03, 2025 - 12:25 EDT
This incident affects: Occupational Health/Employee Health.