Our teams have confirmed that WoundExpert performance has remained stable. All users should be able to log in and use the application as expected.
We will continue to monitor system performance as part of our standard reliability checks, but no further impact is anticipated at this time.
If any users continue to experience issues, please submit a Support case so we can assist right away.
Thank you for your patience and partnership.
The Net Health Team
Posted Nov 06, 2025 - 08:18 EST
Monitoring
Our teams have taken action to restore service, and WoundExpert access is now stabilized. Users should be able to log in and continue app functions as expected.
We will continue to monitor performance closely to ensure sustained stability. If any users are still experiencing issues, please notify Support so we can assist right away.
Thank you for your patience while we worked to restore service.
The Net Health Team
Posted Nov 05, 2025 - 13:03 EST
Investigating
We are currently investigating an issue where some users are experiencing difficulty accessing or loading the WoundExpert application. This may present as the application failing to load or returning an error message.
The system is accessible for some users and unavailable for others. Our Reliability and Engineering teams are actively working to identify the cause and restore full availability.
We will provide an update as additional information becomes available.