IMPORTANT: WoundExpert and ReDoc Feedback Form Submission Issues
Incident Report for Net Health StatusPage
Update
Net Health would like to remind all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support as expected. Users may notice that the usual automated confirmation email with a case number is not being received after submission.

Please be aware that the feedback link and page will be phased out over the next few months and replaced with an enhanced in-app chat feature.

In the meantime, we kindly ask that you use one of the options listed on Net Health's Contact Page to reach out to Support directly.
https://www.nethealth.com/contact/

We sincerely apologize for any inconvenience this may cause and appreciate your understanding and cooperation as we work to improve your support experience.

Thank you,
The Net Health Team
Posted Dec 10, 2024 - 09:29 EST
Update
Net Health would like to remind all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support as expected. Users may notice that the usual automated confirmation email with a case number is not being received after submission.

Please be aware that the feedback link and page will be phased out over the next few months and replaced with an enhanced in-app chat feature.

In the meantime, we kindly ask that you use one of the options listed on Net Health's Contact Page to reach out to Support directly.
https://www.nethealth.com/contact/

We sincerely apologize for any inconvenience this may cause and appreciate your understanding and cooperation as we work to improve your support experience.

Thank you,
The Net Health Team
Posted Dec 06, 2024 - 07:29 EST
Update
Net Health would like to remind all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support as expected. Users may notice that the usual automated confirmation email with a case number is not being received after submission.

Please be aware that the feedback link and page will be phased out over the next few months and replaced with an enhanced in-app chat feature.

In the meantime, we kindly ask that you use one of the options listed on Net Health's Contact Page to reach out to Support directly.
https://www.nethealth.com/contact/

We sincerely apologize for any inconvenience this may cause and appreciate your understanding and cooperation as we work to improve your support experience.

Thank you,
The Net Health Team
Posted Dec 02, 2024 - 07:14 EST
Update
Net Health would like to remind all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support as expected. Users may notice that the usual automated confirmation email with a case number is not being received after submission.

Please be aware that the feedback link and page will be phased out over the next few months and replaced with an enhanced in-app chat feature.

In the meantime, we kindly ask that you use one of the options listed on Net Health's Contact Page to reach out to Support directly.
https://www.nethealth.com/contact/

We sincerely apologize for any inconvenience this may cause and appreciate your understanding and cooperation as we work to improve your support experience.

Thank you,
The Net Health Team
Posted Nov 29, 2024 - 13:29 EST
Update
Net Health would like to remind all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support as expected. Users may notice that the usual automated confirmation email with a case number is not being received after submission.

Please be aware that the feedback link and page will be phased out over the next few months and replaced with an enhanced in-app chat feature.

In the meantime, we kindly ask that you use one of the options listed on Net Health's Contact Page to reach out to Support directly.
https://www.nethealth.com/contact/

We sincerely apologize for any inconvenience this may cause and appreciate your understanding and cooperation as we work to improve your support experience.

Thank you,
The Net Health Team
Posted Nov 27, 2024 - 08:10 EST
Update
Net Health would like to inform all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support correctly. Users may notice that, upon submitting a Feedback Form, the typical automated confirmation email with a case number is not being received.

Please note that the feedback link and page will be phased out and replaced by in-app chat over the next few months.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/

We apologize for any inconvenience this may cause and thank you for your cooperation.

Thank you,
Net Health Team
Posted Nov 26, 2024 - 17:10 EST
Monitoring
Net Health would like to inform all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support correctly. Users may notice that, upon submitting a Feedback Form, the typical automated confirmation email with a case number is not being received.

Please note that the feedback link and page will be phased out and replaced by in-app chat over the next few months.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/

We apologize for any inconvenience this may cause and thank you for your cooperation.

Thank you,
Net Health Team
Posted Nov 26, 2024 - 11:14 EST
Investigating
Net Health would like to inform all clients that the Feedback Form for case submissions, embedded within the application, is currently not routing all requests to Net Health Support correctly. Users may notice that, upon submitting a Feedback Form, the typical automated confirmation email with a case number is not being received.

Please note that the feedback link and page will be phased out and replaced by in-app chat over the next few months.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/

We apologize for any inconvenience this may cause and thank you for your cooperation.

Thank you,
Net Health Team
Posted Nov 26, 2024 - 11:12 EST
This incident affects: WoundExpert and ReDoc.