Issues for hosted clients accessing agility.nethealthapps.com

Incident Report for Net Health StatusPage

Resolved

During a planned infrastructure maintenance window, our team performed a firmware update to our network access layer as part of an ongoing initiative to modernize our licensing infrastructure. The updated firmware version introduced an unexpected incompatibility with our existing license configuration, which caused affected systems to default to a reduced service tier and restricted access to the agility.nethealthapps.com platform.

Upon identifying the issue, we engaged directly with our vendor's support team to resolve the license incompatibility. When that path was not successful, we attempted to roll back the firmware to the prior version; however, the updated firmware did not support a downgrade path. We then accelerated our transition to the vendor's updated online licensing model, which resolved the incompatibility and fully restored access.

Root Cause: A firmware update introduced an incompatibility with the existing license configuration, causing the system to restrict platform access.

Resolution: Transition to online licensing, which eliminated the incompatibility and restored full access.

Next Steps: We are reviewing our change management process for infrastructure updates to ensure compatibility validation is completed prior to deployment, reducing the risk of similar issues in the future.

We apologize for the disruption and appreciate your patience while our team worked to restore service.
Posted Apr 09, 2026 - 08:44 EDT

Monitoring

A fix has been put in place and access to http://agility.nethealthapps.com should be restored. If you are experiencing any issues still, please contact support.
Posted Apr 08, 2026 - 14:47 EDT

Update

We have escalated the issue with Citrix support and are actively working with them to restore services as soon as possible.
Posted Apr 08, 2026 - 12:30 EDT

Identified

Our IT team has identified the issue and is currently working on a solution.
Posted Apr 08, 2026 - 10:18 EDT

Investigating

We are currently investigating issues accessing agility.nethealthapps.com to access the applications.
Posted Apr 08, 2026 - 09:05 EDT
This incident affected: Occupational Health/Employee Health.