Batch Print Performance Issue – Delays in Processing

Incident Report for Net Health StatusPage

Resolved

Our Engineering team has completed the investigation and implemented fixes to address the Batch Print performance delays. Monitoring shows no further issues have been reported, and Batch Print requests are processing as expected.

Thank you for your patience while we worked to resolve this.
If you experience any further problems, please reach out to our Support team for assistance.

Thank you,
The Net Health Team
Posted Sep 15, 2025 - 09:03 EDT

Investigating

We are investigating an issue causing some Batch Print requests to remain stuck in a loading state and not complete as expected. Our Engineering team is actively working to identify the root cause and implement a fix.

We recognize how important Batch Print is to your daily workflow and sincerely apologize for any disruption this may cause. Thank you for your patience and understanding while we work to resolve this issue as quickly as possible.

Thank you,
The Net Health Team
Posted Sep 11, 2025 - 10:00 EDT
This incident affected: WoundExpert.