IMPORTANT: Feedback Form Submission Issues
Incident Report for Net Health StatusPage
Update
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/


We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted Apr 12, 2024 - 16:48 EDT
Update
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/


We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted Feb 27, 2024 - 08:26 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 19, 2024 - 10:30 EST
Update
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/


We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted Feb 19, 2024 - 09:02 EST
Update
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

http://www.nethealth.com/contacts

We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted Feb 15, 2024 - 14:05 EST
Update
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

http://www.nethealth.com/contacts


We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted Feb 06, 2024 - 15:40 EST
Update
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

https://www.nethealth.com/contact/


We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted Jan 04, 2024 - 17:06 EST
Identified
The issue has been identified and a fix is being implemented.
Posted May 25, 2023 - 14:55 EDT
Investigating
Net Health would like to reinforce to all clients that the Feedback Form for case submission, embedded in the application, is currently not delivering all requests to Net Health Support correctly. Users will notice that, upon submission of a Feedback Form, the usual expected behavior of receiving an automated submission confirmation email with a case number is not happening.
We currently do not have a timeline for the fix.

In the meantime, please utilize one of the options listed on Net Health's contact page to reach out to Support:

http://www.nethealth.com/contacts


We apologize for any inconvenience this may cause and thank you for your cooperation.
Posted May 25, 2023 - 14:54 EDT
This incident affects: Wound Care (WoundExpert) and Therapy for Hospital & Private Practice (Redoc xFit).