Support Phone System Disruptions – Please Contact Us via Email
Incident Report for Net Health StatusPage
Resolved
We are pleased to inform you that the issue with our phone system has been resolved, and all communication channels are now fully operational.

Thank you for your patience, and feel free to reach out if you need any further assistance.

Thank you,
Net Health Team
Posted Nov 11, 2024 - 13:49 EST
Investigating
We are currently experiencing issues with our phone system, which is not delivering all inbound calls appropriately. If you are having trouble reaching us by phone, please email us for assistance.

Support Contact info can be found here: https://www.nethealth.com/contact/

We apologize for the inconvenience and appreciate your patience and understanding while we work to resolve this issue.

Thank you,
Net Health Team
Posted Nov 11, 2024 - 13:29 EST
This incident affected: WoundExpert, ReDoc, Occupational Health/Employee Health, FOTO Analytics, Optima, Tissue Analytics, Value-Based Care Solutions, Casamba Skilled, and TherapySource.