Billing Module Latency – Multi-Platform

Incident Report for Net Health StatusPage

Resolved

The latency issue affecting the Billing module in the Net Health Therapy and WoundExpert applications has been fully resolved. System performance remains stable, and no further impact has been observed.

Thank you for your patience.

The Net Health Team
Posted May 09, 2025 - 08:20 EDT

Monitoring

The latency issues affecting the Billing module in both the Net Health Therapy (Hospitals and Private Practice) and Net Health WoundExpert applications have been addressed. System performance has stabilized, and our teams are continuing to closely monitor to ensure ongoing functionality.

We appreciate your patience and understanding as we worked through this issue.

Thank you,
The Net Health Team
Posted May 08, 2025 - 17:28 EDT

Investigating

We are aware that clients are experiencing latency when attempting to access the Billing module in both the Net Health Therapy for Hospitals and Private Practice, as well as the Net Health Wound Care applications.
Our IT teams have been alerted and are actively working to resolve the issue.

We apologize for the inconvenience and appreciate your patience as we work to restore full functionality.

Thank you,
The Net Health Team
Posted May 08, 2025 - 14:03 EDT
This incident affected: WoundExpert and ReDoc.