Occupational Health: Self-Hosted clients, Quest Order/Results Interfaces down

Incident Report for Net Health StatusPage

Monitoring

We have implemented a fix and are seeing messages come through. We will continue to monitor to ensure there are no further issues.
Posted Jun 15, 2026 - 13:18 EDT

Identified

We have identified the issue and are working on getting a solution rolled out.
Posted Jun 15, 2026 - 11:00 EDT

Investigating

We are currently investigating an issue with self-hosted clients using Quest Order/Result interfaces being down.
Posted Jun 15, 2026 - 09:41 EDT
This incident affects: Occupational Health/Employee Health.