Unable to log into the application and reported Latency.
Incident Report for Net Health StatusPage
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 21:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2022 - 15:22 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 19, 2022 - 15:06 EDT
Investigating
Net Health is aware that some users are not able to log into the application and also experiencing Latency within the app.
We are actively investigating the issue.
We apologize for the inconvenience and thank you for your patience.

Thank you,
Net Health Team
Posted Sep 19, 2022 - 13:31 EDT
This incident affected: Wound Care (WoundExpert).