CliniSign Errors: Unable to Select Certain Physicians in Documentation

Incident Report for Net Health StatusPage

Monitoring

We’ve identified the root cause of the issue and implemented a solution. Users have confirmed that they are now able to successfully add physicians to documents.

Our team is actively monitoring the situation to ensure continued stability.
Posted Aug 29, 2025 - 09:22 EDT

Investigating

Net Health is aware of an ongoing issue affecting the CliniSign application. As a result, clinicians may be unable to select certain physicians within documentation. Users may also encounter the following error:

“NPI Verification service was unreachable. The error was: An error has occurred.”

Our team is actively investigating and working to resolve the issue as quickly as possible. We appreciate your patience and understanding as we work to restore full functionality.

Thank you,
The Net Health Team
Posted Aug 29, 2025 - 08:28 EDT
This incident affects: Optima.