TherapySource System login and system refreshing issue

Incident Report for Net Health StatusPage

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2026 - 16:03 EDT

Update

We are continuing to investigate the issue. Updates are actively being applied.
Posted Sep 22, 2026 - 14:44 EDT

Update

We are continuing to investigate the issue. Updates are actively being applied.
Posted Sep 22, 2026 - 13:37 EDT

Investigating

BU: Rehab Therapy
Product: Therapysource
Title/Subject: Therapysource application refreshing



Message:
We are currently investigating an issue affecting Therapysource. Clients may see the system refreshing continuously after login, ore be unable to login to the application.

We are actively investigating the issue to resolve it as soon as possible. We will provide updates as more information becomes available.

Thank you for your patience,

- The Net Health Team
Posted Sep 22, 2026 - 12:08 EDT
This incident affects: TherapySource.