Vendor Portal Login Issue – Service Disruption

Incident Report for Net Health StatusPage

Resolved

This issue has been resolved. Login access to the WoundExpert Vendor Portal has been restored, and users should no longer experience errors when attempting to log in.

If you are experiencing any issues, please reach out to Support.

Thank you,
— The Net Health Team
Posted Jul 30, 2026 - 14:44 EDT

Identified

We are currently investigating an issue affecting login access to the WoundExpert Vendor Portal. Some users may experience an error page when attempting to log in.

Our team has identified the issue and is actively working toward a resolution. We will provide updates as more information becomes available.

Thank you,
– The Net Health Team
Posted Jul 30, 2026 - 10:47 EDT
This incident affected: WoundExpert.