Tissue Analytics - Intermittent Latency on Web Portal and Mobile App

Incident Report for Net Health StatusPage

Resolved

This incident has been resolved.
Posted May 26, 2026 - 14:09 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2026 - 11:18 EDT

Investigating

Net Health is aware of an issue where some users are experiencing latency at login and while navigating within the Tissue Analytics workflow on both the web portal and mobile app. Our team is actively investigating the root cause. In the meantime, refreshing the page may help alleviate latency symptoms.

We will provide updates as they become available. We apologize for the inconvenience and appreciate your patience.

Thank you,
The Net Health Team
Posted May 26, 2026 - 11:10 EDT
This incident affected: Tissue Analytics.