Some Users Experiencing Latency and Errors in the COM Application

Incident Report for Net Health StatusPage

Monitoring

We've pinpointed the problem and are presently applying a solution. Users have reported successful logins, and we're actively monitoring the situation.
Posted Apr 10, 2026 - 12:33 EDT

Investigating

Net Health is aware that some users are currently experiencing latency and errors when logging in to or navigating the Care Operations Management application. Reported errors include:

"This Application is already open"
"Your internet connection has been lost"

Our Platform team has been alerted and is actively working to resolve the issue as quickly as possible. We appreciate your patience and will provide an update as more information becomes available.

Thank you,
Net Health Team
Posted Apr 10, 2026 - 11:21 EDT
This incident affects: Optima.