ReDoc and WoundExpert Service Disruption Notice - Unable to access the application
Incident Report for Net Health StatusPage
Postmortem

WoundExpert and ReDoc experienced a full outage yesterday morning, Thursday October 17th, and again this morning, Friday, October 18th. These two events were unrelated.

Thursday’s disruptions:

  • Root cause: A database service went into an unhealthy memory state and was unavailable due to critical services shutting down unexpectedly, causing the unplanned outage to our applications.
  • Preventative measure: In the near-term, these database services will more regularly be recycled to ensure service health. Longer term, our Infrastructure and Engineering teams are consolidating all data and services to Microsoft Azure, which will provide superior stability and reliability over our current infrastructure deployment model. We expect to be fully migrated to this new model by the end of the year.

Today’s disruption:

  • Root cause: This was an issue with our regular bi-weekly code deployment to production.
  • Immediate action taken: The code was rolled back to the previous version.

    • Preventative measures are being investigated by the team.
Posted Oct 18, 2024 - 16:25 EDT

Resolved
We have not received any further reports of this issue and are closing the incident. If you experience any related issues, please reach out to our support team. Thank you for your understanding and patience.

Thank you,
Net Health Team
Posted Oct 17, 2024 - 13:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2024 - 09:05 EDT
Update
We are continuing to investigate this issue.
Posted Oct 17, 2024 - 08:08 EDT
Investigating
We are currently aware that clients are unable to access the application. Our team is actively working to resolve the issue and restore service as quickly as possible. We apologize for the inconvenience and appreciate your patience. Further updates will be provided as soon as available.

Thank you,
Net Health
Posted Oct 17, 2024 - 08:00 EDT
This incident affected: WoundExpert and ReDoc.