WoundExpert Clinical Documentation Error Message

Incident Report for Net Health StatusPage

Resolved

The root cause was a technical hardware failure. This incident has been resolved.
Posted Feb 28, 2025 - 14:01 EST

Update

We are continuing to investigate this issue.
Posted Feb 28, 2025 - 12:40 EST

Investigating

We are aware that some clients are encountering an error message stating, "An error has occurred. Please contact Net Health Customer Support if this continues," while documenting in various charts. Our team is actively investigating the issue and working on a resolution.
We will provide updates as more information becomes available.

Thank you for your patience.
The Net Health Team
Posted Feb 28, 2025 - 10:29 EST
This incident affected: WoundExpert.