Performance has stabilized for affected hosted Agility clients. Users should no longer be experiencing slowness or login issues.
What was done: Our infrastructure team successfully moved all affected virtual machines off the impacted host and distributed them across the remaining healthy hosts in our environment. This has restored normal application performance.
What's next: Fully replacing the impacted host requires a scheduled maintenance window to do safely without risk of further disruption. We will communicate that maintenance in advance through our standard notification process.
Your data was not affected at any point during this incident.
We will continue monitoring performance and will post a final resolution update once the host replacement has been completed during scheduled maintenance.
Posted Mar 06, 2026 - 15:12 EST
Update
We are currently experiencing performance issues affecting a subset of hosted Agility clients. Some users may be experiencing slowness or difficulty logging in.
What's happening: One of our application host machines is experiencing elevated CPU load. This host is responsible for running the Agility application, and the performance issue is causing slowness for clients whose servers are running on it.
What we're doing: Our infrastructure team is actively moving affected servers off the impacted host and onto a new host to restore normal performance. We are also evaluating additional host capacity to accelerate the process.
Your data is not at risk: The host experiencing issues is separate from the servers that store and manage your data. Your data infrastructure is fully operational and unaffected.
Posted Mar 06, 2026 - 13:43 EST
Identified
Our IT team has identified the issue being with one of the host machines and it working to resolve the issue.
Posted Mar 06, 2026 - 12:18 EST
Investigating
We are currently investigating reports of users experiencing slowness/unable to log in.
Posted Mar 06, 2026 - 11:37 EST
This incident affected: Occupational Health/Employee Health.