Some users are experiencing latency/slowness when attempting to login to COM.
Incident Report for Net Health StatusPage
Resolved
Net Health Support has not received any additional reports of the issue. This incident is resolved.

Thank you,
Net Health team
Posted Apr 26, 2024 - 17:22 EDT
Monitoring
We have implemented a fix and are currently monitoring for any additional reports of the issue.

Thank you,
Net Health Team
Posted Apr 26, 2024 - 11:53 EDT
Investigating
Net Health is aware some clients are experiencing latency/slowness when attempting to login to Care Operations Management application. We are working as quickly as possible to resolve the issue and apologize for the inconvenience.

Thank you,
Net Health team
Posted Apr 26, 2024 - 08:33 EDT
This incident affected: Therapy for SNF and Home Health (Optima).