Batch Finalize Error – Service Disruption

Incident Report for Net Health StatusPage

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 13:54 EDT

Monitoring

A fix has been issued for the issue affecting the batch finalize process in WoundExpert. Users should no longer experience a timeout error when finalizing a batch.

We are monitoring the results to confirm full resolution and will provide a final update once verified.

Thank you,
– The Net Health Team
Posted Jul 31, 2026 - 13:17 EDT

Investigating

We are currently investigating an issue affecting the batch finalize process in WoundExpert. Some users may experience a timeout error when attempting to finalize a batch for any date range.

Our team has identified a potential cause and is actively working toward a resolution. We will provide updates as more information becomes available.

Thank you,
– The Net Health Team
Posted Jul 31, 2026 - 12:45 EDT
This incident affected: WoundExpert.