Microsoft 365 Services Disruption – Support Phone Contact Recommended

Incident Report for Net Health StatusPage

Resolved

The Microsoft 365 service disruption impacting Outlook, Microsoft Teams, and related collaboration services has been resolved. This was a Microsoft-side infrastructure issue that affected users across North America and was not specific to Net Health.

All services should now be functioning normally.

Thank you for your patience.
– The Net Health Team
Posted Jan 23, 2026 - 10:29 EST

Identified

We are currently aware of a Microsoft 365 service disruption impacting email and collaboration services, including Outlook and Microsoft Teams. This is a Microsoft-related issue and is not specific to Net Health.

During this time, clients may experience delays or issues sending or receiving messages via email or Teams.

If you need immediate assistance, please contact Support by phone so we can assist you without delay.

We are actively monitoring the situation and will provide updates as more information becomes available.

Thank you,
-The Net Health Team
Posted Jan 22, 2026 - 15:52 EST
This incident affected: WoundExpert, ReDoc, Occupational Health/Employee Health, FOTO Analytics, Optima, Tissue Analytics, Value-Based Care Solutions, Casamba Skilled, and TherapySource.