Issue with Image Upload Analysis and Measurements

Incident Report for Net Health StatusPage

Resolved

The issue impacting image uploads not completing analysis and not generating measurements has now been resolved.

Our teams have implemented corrective actions and are actively monitoring system performance to ensure continued stability.

If you continue to experience any difficulty uploading images or receiving measurements, please reach out to Net Health Support so we can assist you promptly.

We sincerely appreciate your patience while this was addressed.

Thank you,
The Net Health Team
Posted Jan 13, 2026 - 08:30 EST

Identified

Net Health is aware that users are receiving an error uploading new images that are not completing analysis and not producing measurements.
We are actively investigating the issue.

We apologize for the inconvenience and thank you for your patience.

Thank you,
The Net Health Team
Posted Jan 12, 2026 - 14:33 EST
This incident affected: Tissue Analytics.