Unable to Select Certain Physicians in Documentation

Incident Report for Net Health StatusPage

Identified

We've identified the root of the issue and are currently applying a solution. Users have begun reporting successful attempts to add physicians to documents, and we are actively monitoring the situation to ensure stability.

Thank you,
Net Health Team
Posted Jul 22, 2025 - 12:19 EDT

Investigating

Net Health is aware of an ongoing issue affecting the CliniSign application. As a result, clinicians may be unable to select certain physicians within documentation.

Our team is actively investigating and working to resolve the issue as quickly as possible. We appreciate your patience and understanding during this time.

Thank you,
The Net Health Team
Posted Jul 22, 2025 - 09:18 EDT
This incident affects: Optima.