Claims are continuing to process successfully under our temporary solution.
We’re working closely with Change Healthcare on a permanent fix and will keep you informed as progress is made.
Thank you, Net Health Team
Posted 1 day ago. Apr 28, 2025 - 17:08 EDT
Update
At this time, there are no new updates to share. Claims are continuing to process successfully under our temporary solution.
We’re working closely with Change Healthcare on a permanent fix and will keep you informed as progress is made.
Thank you, Net Health Team
Posted 5 days ago. Apr 25, 2025 - 08:26 EDT
Update
We’ve temporarily brought the on-prem server back online to restore claims file flow to Change Healthcare. Files are currently transmitting successfully. This is a short-term solution while we wait for Change Healthcare to complete IP whitelisting for our cloud server.
We’ll continue to monitor the situation and provide updates as they become available.
Thank you for your patience.
Posted 5 days ago. Apr 24, 2025 - 14:38 EDT
Identified
We’ve identified the issue affecting connectivity to the Change Healthcare sFTP site and are actively working with their team on a resolution. Outbound file transmissions remain impacted during this time.
We’ll continue to provide updates as the resolution progresses and appreciate your continued patience while we work to restore full functionality.
Thank you, Net Health Team
Posted 6 days ago. Apr 24, 2025 - 09:35 EDT
Investigating
We are currently unable to establish a connection to the Change Healthcare sFTP site from any location. This is impacting the transmission of outbound files.
We have reached out to Change Healthcare and are in the process of identifying the appropriate escalation path to engage their technical support team.
Updates will be posted as we receive additional information. We appreciate your patience while we work to restore connectivity.