Wound Expert | Batch Print Latency

Incident Report for Net Health StatusPage

Monitoring

We have identified the root cause of the batch print issue and our team is actively monitoring as the fix is validated. We believe the issue is contained, but want to ensure full stability before marking this resolved.

If you are still experiencing batch print requests getting stuck, please reach out to our Support team directly and we will prioritize your case.

Thank you again for your patience and understanding.

Thank you,
-The Net Health Team
Posted Mar 18, 2026 - 08:40 EDT

Investigating

We are currently aware of an issue affecting some users where batch print requests become stuck in a loading state and do not complete as expected. Our technical team is actively investigating the matter and working diligently toward a resolution.

We understand how important this functionality is to your workflow and sincerely apologize for any disruption this may be causing. We will continue to provide timely updates as more information becomes available.

Thank you for your continued patience and understanding.

Thank you,
The Net Health Team
Posted Mar 17, 2026 - 15:13 EDT
This incident affects: WoundExpert.