All hosted clients unable to launch any Citrix applications

Incident Report for Net Health StatusPage

Monitoring

Our platform team have identified and corrected the issue. All hosted clients should be able to log in. We will provide a RCA tomorrow after further investigation into the cause of the outage, which will then be posted here. Thank you all for your patience and understanding.
Posted Oct 05, 2025 - 19:36 EDT

Investigating

We are currently investigating the issue with all hosted clients being unable to launch any Citrix applications.
Posted Oct 05, 2025 - 18:07 EDT
This incident affects: Occupational Health/Employee Health.