Intermittent “Contact Client Services” Errors

Incident Report for Net Health StatusPage

Resolved

Our engineering team has implemented a fix, and the system is now functioning as expected. We are no longer seeing new reports of the “Contact Client Services” error.

If you continue to experience any issues saving documentation, please reach out to Support so we can review case details and assist as needed.

Thank you for your patience.

-The Net Health Team
Posted Nov 06, 2025 - 08:15 EST

Identified

We are aware of an issue causing some users to intermittently see the “Contact Client Services” error when saving documentation. Not all users are affected.
Our engineering team has identified the source of the issue and is actively working to restore full functionality.
We will provide an update as additional information becomes available.

Thank you for your patience.

The Net Health Team
Posted Nov 05, 2025 - 11:02 EST
This incident affected: WoundExpert.