Issue with Support Email Case Submission tool
Incident Report for Net Health StatusPage
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 10:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2024 - 09:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 01, 2024 - 18:25 EDT
Investigating
Net Health is aware of an issue with our support email case submissions platform as requests are not being delivered correctly. Users are not receiving the usual automated confirmation email with a case number or receiving email responses from Support.

In the meantime, please contact Support via Phone or view current status in Communities.

https://www.nethealth.com/contact/

We apologize for any inconvenience this may cause and thank you for your patience.

Thank you,
Net Health Team
Posted Jul 01, 2024 - 15:13 EDT
This incident affected: WoundExpert, ReDoc, Occupational Health/Employee Health, FOTO Analytics, Optima, Tissue Analytics, Value-Based Care Solutions, Casamba Skilled, and Therapy for Clinics.