Our engineering team has requeued. interface pdfs. If there are still visits with the documentation showing as pending or not sent, please reach out to Support.
Posted Jun 12, 2026 - 11:17 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 12, 2026 - 09:30 EDT
Update
Our engineering team continues to actively investigate. There is no change in status to report.
We appreciate your patience as we work toward a resolution.
Posted Jun 11, 2026 - 17:15 EDT
Update
At this time, our engineering team continues to actively investigate. There is no change in status to report.
We appreciate your patience as we work toward a resolution.
Posted Jun 11, 2026 - 16:05 EDT
Investigating
Net Health is aware of an issue where some users are experiencing latency, in several areas of the applications . Our engineering team is actively investigating and working toward resolution.
We will provide updates as they become available. We apologize for the inconvenience and appreciate your patience.