Our fax vendor has identified the root cause of the recent faxing performance issues, and their engineering teams are actively implementing corrective actions. Progress is being made, and system performance continues to be closely monitored.
We will provide timely updates as remediation efforts continue and appreciate your patience while this work is completed.
Thank you for your continued partnership and understanding.
Posted Dec 12, 2025 - 10:05 EST
Monitoring
Sfax has shared that system performance is steadily improving. Inbound fax transmissions are now processing in real time, and outbound faxes are progressing through the queues. Both overall performance and the remaining outbound delays are being actively monitored. Net Health will continue to provide updates as progress is made.
Posted Dec 09, 2025 - 08:43 EST
Update
Our third-party vendor, Sfax, has reported improved performance in both processing and portal navigation. However, performance remains below expected levels. The review is ongoing, and we are continuing to monitor the situation closely.
Posted Dec 08, 2025 - 17:29 EST
Investigating
Net Health has been made aware that our third-party vendor, SFax, is experiencing an outage. The Sfax Web Portal is experiencing degraded performance, which can impact user ability to access the site, login, or navigate reliably. This is currently under review, and updates will be provided as soon as possible. Sfax engineers are actively working to resolve the issue, and our team is closely monitoring the situation. We will continue to provide updates as more information becomes available.
If you are impacted, please submit a case to Optima-Support@NetHealth.com with “S-Fax” noted in the subject line to help us triage efficiently. In your email, kindly include: Site name Number of users affected Timestamp(s) when the issue was experienced
We sincerely appreciate your patience and understanding as we work to address this matter.