Occupational Health (Agility): Issue with interfaces and electronic prescribing

Incident Report for Net Health StatusPage

Resolved

What happened:
Today's outage was caused by a hardware failure at a Microsoft Azure network hub that serves as a connection point between our data center and our cloud infrastructure. While we have redundant network connections designed to automatically maintain service during failures of this type, the redundancy did not engage as expected under today's failure conditions.

How we resolved it:
Our networking team identified the failure, made configuration adjustments to our network routing to work around the degraded Azure infrastructure, and restored connectivity while Microsoft continues their own investigation and remediation on their side. Microsoft has acknowledged the issue is on their end and has an active investigation open.

What we're doing to prevent recurrence:
The routing configuration changes made today improve how our network handles situations where a connection is technically present but not fully responsive — a scenario our previous configuration did not account for. We will continue to monitor the environment closely and are tracking Microsoft's investigation for any additional findings that inform further improvements.
Posted May 05, 2026 - 15:13 EDT

Monitoring

Connectivity has been restored for clients using interfaces that connect to Net Health servers and clients using electronic prescribing. We are actively monitoring to confirm full stability.

Current status:
Services appear to be functioning normally. We will continue to monitor and will provide a final update once we have confirmed the issue is fully resolved.

Thank you for your patience during this disruption.
Posted May 05, 2026 - 13:40 EDT

Update

What has been restored:
Network connectivity to our infrastructure has been partially restored. Work continues on full service restoration.
Posted May 05, 2026 - 12:51 EDT

Identified

We have identified the cause of the connectivity issues affecting interfaces and electronic prescribing.

What we found:
A failure in a network pathway between our data center and cloud infrastructure has been confirmed. Our team is working with our network provider to restore service.

Who is affected:
Clients using interfaces that connect to Net Health servers and clients using electronic prescribing.

Current status:
Restoration is in progress. We will provide an update once service has been restored.
We appreciate your patience and will share further details as they become available.
Posted May 05, 2026 - 11:16 EDT

Investigating

We are currently investigating an issue affecting connectivity to for interfaces that connect to Net Health servers and for all clients doing electronic prescribing.

What we know:
A network connectivity failure has been identified between our data center and our cloud infrastructure. Our team is actively working to restore service.

Who is affected:
Clients using interfaces that connect to Net Health servers, and clients who do electronic prescribing.

Current status:
Investigation is in progress. We will provide an update as we learn more.
We apologize for the disruption and will share further details as they become available.
Posted May 05, 2026 - 10:25 EDT
This incident affected: Occupational Health/Employee Health.