FOTO Outage June 7th, 2026

Incident Report for Net Health StatusPage

Update

FOTO has been restored to expected functionality. Please submit a support ticket if you have any issues. Thank you.
FOTO Analytics
Posted Jun 07, 2026 - 17:46 EDT

Update

FOTO has been restored to expected functionality. Please submit a support ticket if you have any issues. Thank you.
Posted Jun 07, 2026 - 17:37 EDT

Investigating

We are currently investigating an outage that occurred during regular maintenance and have a ticket open with Microsoft for further investigation. We will continue to update this status page as changes are made. Thank you.
Posted Jun 07, 2026 - 10:30 EDT
This incident affects: FOTO Analytics.